Supported browsers

Edsby is a modern web application that uses modern web standards like HTML5 and JavaScript to deliver a powerful and elegant user experience using the web. For this to work properly you need to have a reasonably modern web browser that is designed to support these popular web standards. Browser upgrades are free, and each new version tends to be faster and better than its predecessor, so it is a good idea to keep your browser up to date.

Edsby is tested extensively on relatively recent versions of:

  • Google Chrome
  • Apple Safari
  • Mozilla Firefox
  • Microsoft Internet Explorer

We know that it is not always possible to run the very latest version of a browser, so we do make sure Edsby will work with older, less capable browsers such as Internet Explorer 10. Anything older than IE 10 is not supported.

Cookies Required

Like many modern web applications, Edsby stores a local “cookie” on your computer to help speed things up. You need to make sure you have cookies enabled in your browser for Edsby to work properly.  Consult the help documentation for your browser if you need to find out how to check this browser setting.

JavaScript Required

The Edsby web user experience is built with JavaScript. You need to make sure you have JavaScript enabled in your browser. Consult the help documentation for your browser if you need to find out how to check this browser setting.